CVE-2018-1000168

Click the icon to Follow me:- twitterTelegramRedditDiscord

Summary:

nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.

Reference Links(if available):

  • https://nghttp2.org/blog/2018/04/12/nghttp2-v1-31-1/
  • https://nodejs.org/en/blog/vulnerability/june-2018-security-releases/
  • http://www.securityfocus.com/bid/103952
  • https://access.redhat.com/errata/RHSA-2019:0367
  • https://access.redhat.com/errata/RHSA-2019:0366
  • CVSS Score (if available)

    v2: / MEDIUMAV:N/AC:L/Au:N/C:N/I:N/A:P

    v3: / HIGHCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

    Links to Exploits(if available)

  • Available for Amazon Prime