CVE-2019-5086

Click the icon to Follow me:- twitterTelegramRedditDiscord

Summary:

An exploitable integer overflow vulnerability exists in the flattenIncrementally function in the xcf2png and xcf2pnm binaries of xcftools, version 1.0.7. An integer overflow can occur while walking through tiles that could be exploited to corrupt memory and execute arbitrary code. In order to trigger this vulnerability, a victim would need to open a specially crafted XCF file.

Reference Links(if available):

  • https://talosintelligence.com/vulnerability_reports/TALOS-2019-0878
  • https://www.talosintelligence.com/vulnerability_reports/TALOS-2019-0878
  • https://lists.debian.org/debian-lts-announce/2021/02/msg00014.html
  • CVSS Score (if available)

    v2: / HIGHAV:N/AC:M/Au:N/C:P/I:P/A:P

    v3: / HIGHCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

    Links to Exploits(if available)