CVE-2019-7577

Click the icon to Follow me:- twitterTelegramRedditDiscord

Summary:

SDL (Simple DirectMedia Layer) through 1.2.15 and 2.x through 2.0.9 has a buffer over-read in SDL_LoadWAV_RW in audio/SDL_wave.c.

Reference Links(if available):

  • https://discourse.libsdl.org/t/vulnerabilities-found-in-libsdl-1-2-15/25720
  • https://bugzilla.libsdl.org/show_bug.cgi?id=4492
  • https://lists.debian.org/debian-lts-announce/2019/03/msg00016.html
  • https://lists.debian.org/debian-lts-announce/2019/03/msg00015.html
  • https://lists.fedoraproject.org/archives/list/[email protected]/message/UFYUCO6D5APPM7IOZ5WOCYVY4DKSXFKD/
  • CVSS Score (if available)

    v2: / MEDIUMAV:N/AC:M/Au:N/C:P/I:P/A:P

    v3: / HIGHCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

    Links to Exploits(if available)

  • Available for Amazon Prime