Thu. Jul 7th, 2022

Summary:

** UNSUPPORTED WHEN ASSIGNED ** Polipo through 1.1.1 allows denial of service via a reachable assertion during parsing of a malformed Range header. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Reference Links(if available):

  • https://bugs.gentoo.org/755896
  • https://github.com/jech/polipo/commit/4d42ca1b5849518762d110f34b6ce2e03d6df9ec
  • https://www.openwall.com/lists/oss-security/2020/11/18/1
  • http://www.openwall.com/lists/oss-security/2021/07/18/1
  • CVSS Score (if available)

    v2: / MEDIUMAV:N/AC:L/Au:N/C:N/I:N/A:P

    v3: / HIGHCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

    Links to Exploits(if available)