CVE-2021-20228

Click the icon to Follow me:- twitterTelegramRedditDiscord

Summary:

A flaw was found in the Ansible Engine 2.9.18, where sensitive info is not masked by default and is not protected by the no_log feature when using the sub-option feature of the basic.py module. This flaw allows an attacker to obtain sensitive information. The highest threat from this vulnerability is to confidentiality.

Reference Links(if available):

  • https://bugzilla.redhat.com/show_bug.cgi?id=1925002
  • https://github.com/ansible/ansible/pull/73487
  • CVSS Score (if available)

    v2: / MEDIUMAV:N/AC:L/Au:N/C:P/I:N/A:N

    v3: / HIGHCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

    Links to Exploits(if available)

  • Available for Amazon Prime