CVE-2021-41611

Click the icon to Follow me:- twitterTelegramRedditDiscord

Summary:

An issue was discovered in Squid 5.0.6 through 5.1.x before 5.2. When validating an origin server or peer certificate, Squid may incorrectly classify certain certificates as trusted. This problem allows a remote server to obtain security trust well improperly. This indication of trust may be passed along to clients, allowing access to unsafe or hijacked services.

Reference Links(if available):

  • http://www.squid-cache.org/Versions/v6/changesets/squid-6-43d6b5c81b88ec2256b430c69a872a1e4f324e4a.patch
  • https://github.com/squid-cache/squid/security/advisories/GHSA-47m4-g3mv-9q5r
  • https://lists.fedoraproject.org/archives/list/[email protected]/message/CWQ2WKDWTSO47S3F6XJJ6HGG2ULWEAE4/
  • CVSS Score (if available)

    v2: / MEDIUMAV:N/AC:L/Au:N/C:P/I:N/A:N

    v3: / HIGHCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

    Links to Exploits(if available)

  • Available for Amazon Prime